The incident is finished, all traffic is back to normal.
Posted May 09, 2026 - 12:39 EEST
Update
The incident affecting specific issuer card transactions remains ongoing. Transaction traffic is gradually recovering, and successful authorizations with specific issuer cards are being processed. However, a limited number of errors continue to be observed.
Posted May 09, 2026 - 12:10 EEST
Update
We are continuing investigation for this issue.
Posted May 09, 2026 - 11:30 EEST
Identified
Swedbank Baltic Acquiring POS systems are stable. However, we have identified a service disruption in accepting card payments related to third party systems. We apologize for any inconvenience this may cause.
Posted May 09, 2026 - 11:00 EEST
This incident affected: Cards Acquiring Estonia, Cards Acquiring Latvia, and Cards Acquiring Lithuania.