Disruption in Payment initiation Service related to third party systems

Incident Report for Swedbank Baltic Commerce

Resolved

There were instant payment issues. Instant payment flow restored.
Posted Sep 04, 2026 - 10:30 EEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 04, 2026 - 10:19 EEST

Identified

Swedbank Payment Initiation service system is stable. However, we have identified a SEB service disruption in executing payments related to third party systems.
We apologize for any inconvenience this may cause.
Posted Sep 04, 2026 - 10:16 EEST
This incident affected: Banks for Payment Initiation.