Disruption in Payment initiation Service related to third party systems

Incident Report for Swedbank Baltic Commerce

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 10:20 EEST

Investigating

Swedbank Payment Initiation service system is stable. However, we have identified a service disruption in executing payments related to third party systems.
We apologize for any inconvenience this may cause.
Posted Jul 08, 2026 - 08:30 EEST
This incident affected: Payment initiation service (Swedbank solution).